Boost logo

Boost-Build :

Subject: [Boost-build] BJAM reports "error: Unknown target type EXE" in Ubuntu
From: Alden King (apking_at_[hidden])
Date: 2010-05-22 03:19:51

I'm trying to build the 1.43.0 release from the tarball release. After
untaring I run with a user-specific install path. It
reports success with the bootstrap. When I run bjam, however, I get the
"error: Unknown target type EXE" error. Searching the forums and lists,
it looks like this occurred on Windows three years ago, due to paths not
being handled correctly. But I'm running on Ubuntu (9.10).
The exact error is:

~/boost_1_43_0/tools/build/v2/build/type.jam:146: in type.validate from
module type
error: Unknown target type EXE
~/boost_1_43_0/tools/build/v2/kernel/modules.jam:103: in
from module object(installed-exe-generator)@3
~/boost_1_43_0/tools/build/v2/util/sequence.jam:48: in
sequence.transform from module sequence
~/boost_1_43_0/tools/build/v2/build/generators.jam:227: in
generator.__init__ from module object(installed-exe-generator)@3
~/boost_1_43_0/tools/build/v2/tools/stage.jam:355: in
object(installed-exe-generator)@3.__init__ from module
~/boost_1_43_0/tools/build/v2/kernel/class.jam:88: in new from module class
~/boost_1_43_0/tools/build/v2/tools/stage.jam:396: in load from module stage
~/boost_1_43_0/tools/build/v2/kernel/modules.jam:283: in import from
module modules
~/boost_1_43_0/tools/build/v2/tools/builtin.jam:25: in load from module
~/boost_1_43_0/tools/build/v2/kernel/modules.jam:283: in import from
module modules
~/boost_1_43_0/tools/build/v2/build-system.jam:11: in load from module
~/boost_1_43_0/tools/build/v2/kernel/modules.jam:283: in import from
module modules
~/boost_1_43_0/tools/build/v2/kernel/bootstrap.jam:142: in boost-build
from module
~/boost_1_43_0/boost-build.jam:17: in module scope from module

Am I misconfiguring something? If I don't set a user-local path and
just run


Then I still get the same error. I have two versions of bjam (3.1.18 in
the distribution and 3.1.16 installed) which I've tried, and they both
give me the same error.

Ubuntu 9.10
Kernel 2.6.31-19-generic
gcc --version : 4.4.1 (Ubuntu 4.4.1-4ubuntu9)
bjam 03.1.18 (came with the boost distribution)
bjam 03.1.16 (installed on the system)


PS Sorry if this gets posted twice, mailman wouldn't let me send it
unless I subscribed, and I don't know if it held the original or deleted it.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at