Boost logo

Boost-Build :

Subject: Re: [Boost-build] question regarding compile time switches
From: Johan Nilsson (r.johan.nilsson_at_[hidden])
Date: 2010-06-02 03:04:47

Robert Ramey wrote:
> I have a very wierd situation. I run all the serialization library
> tests with the Jamfile.v2 in BOOSTROOT/libs/serialization/test/Jamfile.v2.
> As far as I can tell, for a given compiler (in this case MSVC 7.1) all
> compilations should be run with the same switches. However I
> discovered that on some tests, the /Wp64 switch is used and others not.
> The
> results in in comparable results in my test results. Here is what I mean:
> I run:
> bjam -n toolset=msvc-7.1 test_valarray_text_archive >t.log &
> and
> $ bjam -n toolset=msvc-7.1 test_vector_text_archive >t2.log &
> The console output from he above is attached.
> In the valarray test, there is a /WP64 switch and in the vector test
> there is no such switch.

>From your valarray test log:

 -Fo"..\..\..\bin.v2\libs\serialization\test\test_valarray_text_archive.test\msvc-7.1\debug\threading-multi\test_valarray.obj"    -TP /Z7 /Od /Ob0 /W4 /GR /MDd /Zc:forScope /Zc:wchar_t /Wp64              <-- /GB /Op /wd4675 /EHs -Gy -wd4996 -c---From your vector test log:---file..\..\..\bin.v2\libs\serialization\test\test_vector_text_archive.test\msvc-7.1\debug\threading-multi\test_vector.obj.rsp"test_vector.cpp" -Fo"..\..\..\bin.v2\libs\serialization\test\test_vector_text_archive.test\msvc-7.1\debug\threading-multi\test_vector.obj"    -TP /Z7 /Od /Ob0 /W4 /GR /MDd /Zc:forScope /Zc:wchar_t /Wp64            <-- /GB /Op /wd4675 /EHs -Gy -wd4996 -c ---As far as I can see the switch is present for both tests, or am I missingsomething?/ Johan

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at