Boost logo

Boost-Build :

Subject: Re: [Boost-build] jam/python function calling
From: Juraj Ivančić (juraj.ivancic_at_[hidden])
Date: 2010-07-15 05:15:23


On 14.7.2010 21:06, Vladimir Prus wrote:
> I am starting to think that using exact signature from jam code is the
> best approach here. Using magic lists of integers that describe unpacking
> appears to be unmaintainable (even though the description has to be
> written only once, it better be readable)

Exact signature needlessly duplicates parameter names. This hardly
increases readability IMHO.

How about this:

@jam_signature( [ '..*', '*', '?', '?' ] )
def flags(rule_or_module, variable_name, condition, values, unchecked,
hack_hack):

or

@jam_signature( "..*:*:?:?" )
def flags(rule_or_module, variable_name, condition, values, unchecked,
hack_hack):


Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk