Boost logo

Boost-Build :

Subject: Re: [Boost-build] FW: Boost problem with unit test module - a challenge
From: Steven Watanabe (watanabesj_at_[hidden])
Date: 2010-11-27 13:31:43


On 11/17/2010 2:42 AM, gilam.roth_at_[hidden] wrote:
> I got an irritating problem and maybe one of you have the knowledge to help me out.
> Compile and link is the challenge
> I'm working on Solaris (Oracle) and I verify it is one of the newest so no problem should expect using Boost.
> I downloaded boost_1_44_0.tar.bz2<>.
> And follow the instructions from
> I checked with the simple program from section 4 and it works fine.
> Great, now happy and cheerful I build a simple test as describe on the unit test module.
> I tried to build it using a make file and failed.
> So I tried as in the previous example
> c++ -I ~/boost_1_44_0 TestBoost.cpp -o g1TestBoost.o
> It gave lots of errors. I got the feeling as if 2 different stl libs are involved.
> What did I done wrong? What should I do to make it right? Is there anybody out there?
> The challenge is to compile it with a make file. Do you know how?
> Thanks.
> Gilam
> The test is copy from the manual.
> TestBoost.cpp
> #include<boost/test/included/unit_test.hpp>

Try #include <boost/test/unit_test.hpp>.
I'm guessing the BOOST_TEST_DYN_LINK is
incompatible with the header only option.

In Christ,
Steven Watanabe

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at