Boost logo

Boost-Build :

Subject: [Boost-build] problems when building boost with clang
From: Ekaterina Sanina (ekaterina.sanina_at_[hidden])
Date: 2010-12-07 22:42:15


I tried to build BOOST with clang 2.8 compiler today, but I encountered some
failures. This is the first time ever I tried to build BOOST, so most likely
I'm doing something wrong. I would appreciate any help to resolve this

I saw an announcement dated March 20, 2010 that clang++ successfully builds
BOOST on, so I followed
instructions on how to do it and I expected to see similar results. The
difference is that I used 2.8 version of the clang compiler and that I
compiled on Linux, not on Mac OS.

(1) First, for comparison reason, I've built BOOST with gcc 4.4.3 compiler,
installed on my system.
I saw some failures/skipped targets...

...failed updating 58 targets...
...skipped 12 targets...
...updated 763 targets...

Is it expected results for gcc?

The reason why some tests failed is because some headers are missing:

libs/regex/build/has_icu_test.cpp:12:30: error: unicode/uversion.h: No such
file or directory
libs/regex/build/has_icu_test.cpp:13:28: error: unicode/utypes.h: No such
file or directory
libs/regex/build/has_icu_test.cpp:14:27: error: unicode/uchar.h: No such
file or directory
libs/regex/build/has_icu_test.cpp:15:26: error: unicode/coll.h: No such file
or directory

Am I missing something???

(2) I was not sure whether gcc compilation results are expected or not, but
I hoped at least to get similar failed/skipped rate for the clang 2.8
compiler. However the results were much worse:

...failed updating 63 targets...
...skipped 309 targets...
...updated 461 targets...

When I analyzed the log file, at some point things went differently
(compared to building BOOST with gcc), namely, pch.hpp.pchi file was not
found. Do you know why this file is not where it's expected to be? Many
tests are skipped/failed later because this file is missing.
Do you know how could I resolve this issue?

clang: error: no such file or directory:
    rm -f
&& "clang++" -x c++-header -O3 -finline-functions -Wno-inline -Wall -pthread
-DBOOST_MATH_TR1_DYN_LINK=1 -DNDEBUG -I"." -I"libs/math/src/tr1" -c

...failed clang-linux.compile.c++.pch
for lack of
for lack of
<pbin.v2/libs/math/build/clang-linux-2.8/release/threading-multi>beta.o for
lack of
for lack of


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at