Boost logo

Boost-Build :

Subject: Re: [Boost-build] [Regex] LNK1181: cannot open input file'shared.obj'
From: Vladimir Prus (ghost_at_[hidden])
Date: 2011-01-21 15:27:55

What is the full command that fail? Could you try with trunk version of Boost.Build, including building a fresh bjam version and making sure you use that one?

Thanks, Volodya

"Tristan Nowak" <tris.sethur_at_[hidden]> wrote:

>That was one of the first things I tried, in fact, I always deleted
>bin.v2 before any rebuilding attempt. The strange thing is that I
>build ANY shared boost libraries now at all, although I somehow managed
>to build e.g. boost::threads before.
>Also, I tried to compile against both MSVC-9.0 and MSVC-10.0 and I get
>the some LNK1181 error with both environments. At some point during my
>tries, though, the file name was static.obj, but I was not able to
>reproduce that.
>Thanks for you help so far,
>Am 21.01.2011 18:44, schrieb John Maddock:
>>> I never tried building DLLs from the MSVC command line, building a
>>> very small dll from the IDE seemed to work fine, though.
>>> Additionally, I somehow managed to build the DLL/Import Libs for
>>> boost::thread before, but know building this gives the same error...
>> The only suggestion I have is to delete all the temporary files
>> generated by Boost.Build under boost-path/bin.v2/ and then try again
>> just in case there's a corrupted file somewhere...
>> HTH, John.
>> _______________________________________________
>> Unsubscribe & other changes:
>Unsubscribe & other changes:

Sent from my Android phone with K-9 Mail. Please excuse my brevity.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at