Boost logo

Boost-Build :

Subject: [Boost-build] Boost build error in build-system.jam
From: Dmitry Timoshenko (dimentiy2k_at_[hidden])
Date: 2011-04-09 21:28:32


I use 3.1.18 to compile my projects. I setup scripts more
then 1 year ago. I checked scripts worked properly.
They also works with boost 1.41.

But with boost 1.45 the boost build version 3.1.18 doesn't work due to
it's too old for boost 1.45.

I downloaded nigthly build and got an error. Then I took boost build
from boost 1.45 and got the same error.

Here it is:

D:/work/extra/boost-build\build-system.jam:722: in load
*** argument error
* rule project.load ( jamfile-location )
* called with: ( )
* missing argument jamfile-location
D:/work/extra/boost-build/build\project.jam:53:see definition of rule
'load' being called
D:\work\extra\boost-build\kernel\modules.jam:283: in import
D:\work\extra\boost-build\kernel\bootstrap.jam:142: in boost-build
D:\work\extra\boost-build\boost-build.jam:8: in module scope

May be I'm wrong? May be my scripts cause the error inside boost-build
jam sources?

Please, help me. At present I can only build the projects with boost
1.41. How to resolve this?

I also want to ask. Why the official boost build page has the stable
build reference to 3.1.18 version
when the 3.1.19 is already distributed with boost?
This can mislead sometimes when as usually go to the home page of a project
and think yor are downloading latest stable release.

The reference I'm talking about is located here and points here

Thank you.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at