Boost logo

Boost-Build :

Subject: Re: [Boost-build] Trouble building Boost 1.47 64-bit libraries on Linux with gcc. Error is "sorry, unimplemented: 64-bit mode not compiled in"
From: Tim Musson (Tim.Musson_at_[hidden])
Date: 2011-12-12 16:55:22

You are right, the problem was that we do not have the 64-bit compiler
and libraries installed. I was so focused on Boost that I forgot to look
at the larger picture :)

I tried the build on another machine where we have a 64-bit Linux
installation and Boost compiles fine in 64-bit. For others with the same
problem, look here:

Thank you,

On 12/12/2011 4:50 PM, Jürgen Hunold wrote:
> Hi Tim,
> On Monday, 12. December 2011 19:31:51 Tim Musson wrote:
>> I think I must have a basic misunderstanding or incorrect configuration, but
>> I am not able to build 64-bit Boost libraries. The example below is for the
>> Thread library, but the Chrono lib had the same error (but on
>> error_code.cpp). For history, I have compiled the 32-bit versions fine.
> It is good to know that both libraries produces the same error.
>> If it matters, the host processor is 32-bit OS (64-bit Intel proc?) and I
>> want to cross-compile for 64-bit OS and 64-bit Intel / Xeon proc.
>> [user_at_machine boost_1_47_0]$ cat /etc/issue
>> Scientific Linux SL release 4.9 (Beryllium)
>> Kernel \r on an \m
>> [user_at_machine boost_1_47_0]$ uname -a
>> Linux machine 2.6.9-89.0.20.EL #1 Tue Feb 2 19:06:41 CST 2010 i686 i686 i386
>> GNU/Linux
> 2.6 is quite ancient.
>> p.s. I searched the archives for "64-bit mode not compiled in"
>> and found relevant.
> "nothing" missing, maybae?
>> bin.v2/libs/thread/build/gcc-3.4.6/release/address-model-64/threading-multi
>> /pthread/thread.o libs/thread/src/pthread/thread.cpp:1: sorry,
>> unimplemented: 64-bit mode not compiled in
> Okay, this is an ancient gcc 3.4.6 detected.
> And it is this gcc which complains about "sorry, unimplemented: 64-bit mode
> not compiled in".
>> "g++" -ftemplate-depth-128 -O3 -finline-functions -Wno-inline -Wall
>> -pthread -fPIC -m64 -Wno-long-long -DBOOST_ALL_NO_LIB=1
>> "bin.v2/libs/thread/build/gcc-3.4.6/release/address-model-64/threading-mult
>> i/pthread/thread.o" "libs/thread/src/pthread/thread.cpp"
> Search the net or your distribution how to get an 64-bit enabled gcc. (3.4.6
> or newer).
> Yours,
> Jürgen

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at