Boost logo

Boost-Build :

Subject: Re: [Boost-build] cygwin and recent gcc builds
From: François Jacques (francois.jacques_at_[hidden])
Date: 2012-04-13 14:45:25


I've been able to compile bjam under cygwin without problem and it
appears to work fine. I'm using gcc 4.5.3, which is my local default
gcc. Haven't tried with gcc 4.7 though.

2012/4/9 Eric Niebler <eric_at_[hidden]>:
> I've been building and using gcc with cygwin for a while, and then
> patching them into using my user-config.jam. At some point
> in the past what I was doing stopped working. Things build fine, but the
> resulting exe doesn't run (e.g, when I bjam in a test directory).
> First, I get an error about cyggcc_s-sjlj-1.dll not being in the path,
> even though it's in the same directory as the g++.exe executable. My
> user-config.jam has this:
> using gcc : 4.7 : /usr/local/gcc-4.7/bin/g++.exe ;
> I'm pretty sure this used to be sufficient for BBv2, but maybe I need to
> change this so that /usr/local/gcc-4.7/bin gets added to the path
> automatically?
> If I add /usr/local/gcc-4.7/bin to my path manually, I get a different
> problem:
> testing.capture-output
> ../../../bin.v2/libs/proto/test/calculator.test/gcc-0x/debug/link-static/
> /bin/sh: line 2:  3032 Segmentation fault      (core dumped)
> "../../../bin.v2/libs/proto/test/calculator.test/gcc-0x/debug/link-static/calculator.exe"
> "../../../bin.v2/libs/proto/test/calculator.test/gcc-0x/debug/link-static/calculator.output"
> 2>&1
> Clearly, it's picking up a bad dll somewhere, but I don't know which or
> how to debug this. Note: if I run with link=static runtime-link=static,
> the problem goes away, so that's what I usually do.
> Has anybody encountered these problems? Have I got things wrong in my
> user-config.jam? TIA,
> --
> Eric Niebler
> BoostPro Computing
> _______________________________________________
> Unsubscribe & other changes:

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at