Boost logo

Boost-Build :

Subject: Re: [Boost-build] build error
From: Paul (paulsteyn1_at_[hidden])
Date: 2012-07-14 09:02:43

Sounds a bit like an error I was getting a while back on Windows. Can't
remember which module was giving me the error, though.

The subject of my mails was "Errors when compiling Boost on Windows
with MinGW", so you can try searching the mailing list archives for
those emails for more info.

I didn't fix it, but I did manage to work around it, see below.

On Sat, 14 Jul 2012 10:57:27 +0200
Jurko Gospodnetić <jurko.gospodnetic_at_[hidden]> wrote:

> Hi.
> > *Hi, I am installing a software 'Tophat', which requires boost. I
> > compiled boost in a linux system using:
> >
> > ./b2 install --prefix=/users/jwu runtime-link=static link=static
> >
> > I got error message:
> > ...
> Sorry, I can not reproduce your error using msvc on Windows or gcc
> on Cygwin. The same command-line (with a different prefix though)
> works fine here in both cases.
I was getting the error on windows using the MinGW gcc, not Cygwin.
Just following the windows getting started guide.

> > error: Duplicate name of actual target:
> > <p/users/jwu/lib>libboost_thread.a
> > ...
> > error: added properties: <library>object(file-target)@1549
> > <library>object(file-target)@1581 <runtime-link>shared
> > error: removed properties: <library>object(file-target)@822
> > <library>object(file-target)@844 <runtime-link>static
> This seems to indicate something is trying to build the thread
> library with both static and shared runtimes, naming both of the
> resulting library files the same (/users/jwu/lib/libboost_thread.a).
> Try building Boost without the thread library to see if the
> problem is specific to just that library's build definition, i.e. add
> the --without-thread option.
I tried omitting the offending module, but then I just got the error on
another module. The log file did, however, give me a list of modules,
so I built them one by one using the --with-module option, and each one
succeeded (except of course the mpi and python ones, as those were
complaining of different errors, and I didn't need those anyway, so I
ignored them).

I don't know why this is happening, I suspected a misconfig in boost,
but nobody at the time seemed to have anything to add, so I just built
everything one module at a time, and everything worked.

Hope this helps you.


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at