Boost logo

Boost-Build :

Subject: Re: [Boost-build] boost library compile error on Linux 3.2.2-5
From: Lynn Johnson (johnsonl_at_[hidden])
Date: 2012-11-30 06:58:48

Thank you all very much for your help. Yes, 3.2.2-5 is RHEL, my gcc version is 3.2.2 . I did note on your website that Boost testing was not done with gcc versions below 4. Unfortunately, we're porting for a specific customer and they are using very old Linux versions.

I have removed the indicated line from libs/thread/build/Jamfile.v2 and the compile gets further. I will debug the latest issues to see if Boost will work for this project. I think your libraries have a lot to offer and if they aren't the solution today, I hope they will be when we port to a newer Fedora version.

-----Original Message-----
From: boost-build-bounces_at_[hidden] [mailto:boost-build-bounces_at_[hidden]] On Behalf Of ???? ??????
Sent: Friday, November 30, 2012 2:10 AM
To: Boost.Build developer's and user's list
Subject: Re: [Boost-build] boost library compile error on Linux 3.2.2-5

I'm guessing 'Red hat 3.2.2-5' refers to RHEL, and 3.2.2 is the version of gcc used in compiling the OS.

As far as I know, gcc versions below 4 are not supported by boost anyways.

On Fri, 30 Nov 2012, Vladimir Prus wrote:

> On 30.11.2012 01:23, Lynn Johnson wrote:
>> We have a large Windows application that I am trying to port to Linux.
>> Our group has decided to check out Boost the boost libraries for this
>> port. I have downloaded and expanded the Boost .tar file
>> (boost_1_52_0) and am following the instructions listed on the Boost
>> "Getting Started on Unix variants" page. My OS is a virtual machine
>> running Red hat Linux 3.2.2-5. This is the linux version our
>> customer has.
>> I have successfully executed ./ to set up prefixes and
>> specified "-with-libraries" for the thread library. When I run
>> "./b2 install" all compiles are failing with the error "cclplus:
>> unrecognized option '-Wextra' "
>> I would like to try compiling with this option set to "-W" instead of
>> -Wextra but I have been unable to find the Boost file that lists the
>> compiler options. I've googled and seen mention of a
>> boost/status/compiler.cfg file but that file does not exist in the
>> boost/status directory that was unpacked today. I tried running a
>> "find" command from the boost_1_52_0 directory and came up empty.
>> Can someone tell me where the compiler options are declared so I can
>> alter them? Any suggestions you have are greatly appreciated.
> Hi Lynn,
> the compiler options are set in tools/build/v2/tools/gcc.jam - but, I
> don't see -Wextra there. It appears that the thread library adds it
> here:
> libs/thread/build/Jamfile.v2
> if you remove the line that say:
> <toolset>gcc:<cxxflags>-Wextra
> that option will not be passed to the compiler.
> Note that I am not quite sure which Linux you have. If 3.2.2-5 refers
> to your kernel version, then it is of very little interest when building Boost.
> HTH,
> Volodya
> _______________________________________________
> Unsubscribe & other changes:
Unsubscribe & other changes:
This e-mail message and any attachments are confidential
and proprietary to Advion Inc., subject to copyright, and intended only for the use of the named recipient(s). If you are not an intended recipient, you have received this message in error and any review, copying, disclosure, distribution or other use or exploitation of it or its contents is strictly prohibited. If you have received this message in error, please immediately notify the sender and permanently destroy all copies of it.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at