Boost logo

Boost-Build :

Subject: [Boost-build] Cross compile Boost library (Thread, System) for PowerPC
From: studywireless (studywireless_at_[hidden])
Date: 2013-02-20 02:52:41

   I am trying to cross compile Boost library (Thread, System) for PowerPC
architecture. I followed the steps mentioned in a previous post but facing

I run a shell script which sets up my toolchain. The compiler ppc_4xx-g++ is
visible at the shell.

Steps followed:
1. Add the line "using gcc : power : ppc_4xx-g++ ;" to the file
2. Run ./ --prefix=BoostPowerPC in root directory.
3. Run ./b2 install --build-dir=BoostPowerPC toolset=gcc-power --with-thread
--with-system stage

Result: All the directories gets created but compilation fails. I can't
attach the error log (Please send me your email so that I can send you the
error log if you need). Below is the snapshot of the error log.

Component configuration:

    - atomic : not building
    - chrono : not building
    - context : not building
    - date_time : not building
    - exception : not building
    - filesystem : not building
    - graph : not building
    - graph_parallel : not building
    - iostreams : not building
    - locale : not building
    - math : not building
    - mpi : not building
    - program_options : not building
    - python : not building
    - random : not building
    - regex : not building
    - serialization : not building
    - signals : not building
    - system : building
    - test : not building
    - thread : building
    - timer : not building
    - wave : not building

...found 20376 targets...
...updating 10110 targets...
common.mkdir BoostPowerPC
common.mkdir BoostPowerPC/lib
common.mkdir BoostPowerPC/boost
common.mkdir BoostPowerPC/boost/bin.v2
common.mkdir BoostPowerPC/boost/bin.v2/libs
common.mkdir BoostPowerPC/boost/bin.v2/libs/system
common.mkdir BoostPowerPC/boost/bin.v2/libs/system/build
common.mkdir BoostPowerPC/boost/bin.v2/libs/system/build/gcc-power
common.mkdir BoostPowerPC/boost/bin.v2/libs/system/build/gcc-power/release
In file included from ./boost/config/select_stdlib_config.hpp:18,
                 from ./boost/config.hpp:40,
                 from ./boost/system/config.hpp:13,
                 from libs/system/src/error_code.cpp:18:
/opt/ELDK/4.2/ppc_4xx/usr/include/c++/4.2.2/cstddef:50:28: error:
bits/c++config.h: No such file or directory
In file included from /opt/ELDK/4.2/ppc_4xx/usr/include/c++/4.2.2/ios:43,
                 from ./boost/iterator.hpp:17,
                 from ./boost/operators.hpp:86,
                 from ./boost/system/error_code.hpp:17,
                 from libs/system/src/error_code.cpp:19:
Its complaining that the file c++config.h is not found. But the file is
present in the location
/opt/ELDK/4.2/usr/include/c++/4.2.2/powerpc-linux/bits directory

Then I tried to use the tag "include" in the b2 command. But then I get a
error that the file cstddef is not found which is present in the directory
/opt/ELDK/4.2/usr/include/c++/4.2.2. I think I am over writing the include

What do you think is the problem ? Why can't my compiler find the file even
if its present ? Help please.

View this message in context:
Sent from the Boost - Build mailing list archive at

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at