Boost logo

Boost-Build :

Subject: Re: [Boost-build] Cross compile Boost library (Thread, System) for PowerPC - Solution
From: studywireless (studywireless_at_[hidden])
Date: 2013-02-23 03:27:36

I found the solution for this problem

The problem was because of a bug in the compiler. It couldn't recursively
search for directories to find the include folders. When I manually provided
the additional include path, it rejected it stating redundant include path
(since it was in the same directory structure) - Found this by using -v
option. Then I created a directory, created a soft link to the directory
which had the necessary include files and included this new directory in my
include path (Workaround). This worked and I could generate the libraries.

Eg: The include files were present in the directory abc/include/xyz/include
which the compiler was not accepting as I had already specified the path
abc/include. Hence I created a directory alias and linked it to
abc/include/xyz/include. Then I included ./alias as one of the include paths
and it worked. This was a known compiler issue which is fixed in later
versions, I think in 4.6

PS: The idea was not mine but found a similar post online which helped me.

Thanks to all who helped me in this.

View this message in context:
Sent from the Boost - Build mailing list archive at

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at