Boost logo

Boost-Build :

Subject: Re: [Boost-build] Bootstrap.bat fails Win7 vc11 boost 1.55
From: John Reeder (jreeder_at_[hidden])
Date: 2014-02-28 13:39:23

> > Looks like it could be an issue with spaces in the path. Have you tried
> somewhere without spaces?
Yes I tried copying the folder to the drive root then running bootstrap
again same issue.

> It's strange since the above command does not have anything with spaces.
> Joshua, could you go to
> C:\Users\My Name\Code\boost_1_55_0\tools\build\v2\engine
> and run
> .\bootstrap\jam0 -f build.jam --toolset=vc11 -n
> "--toolset-root=C:\Program Files (x86)\Microsoft Visual Studio
> 11.0\Common7\Tools\..\..\VC\ "
> there and send the output?
> - Volodya

When I ran the jam0 executable directly it finishes without issue.

 ...found 159 targets...
...updating 3 targets...
[MKDIR] bin.ntx86

    md "bin.ntx86"

[COMPILE] bin.ntx86\b2.exe

    "cl" "/Fdbin.ntx86/" "/Fobin.ntx86/" /Febin.ntx86\b2.exe "-DNDEBUG"
"/MT" "/O2" "/Ob2" "/Gy" "/GF" "/GA" "/wd4996" "command.c" "compile.c"
"constants.c" "debug.c" "execcmd.c" "frames.c" "function.c" "glob.c"
"hash.c" "hcache.c" "headers.c" "hdrmacro.c" "jam.c" "jambase.c"
"jamgram.c" "lists.c" "make.c" "make1.c" "mem.c" "object.c" "option.c"
"output.c" "parse.c" "pathsys.c" "regexp.c" "rules.c" "scan.c" "search.c"
"subst.c" "w32_getreg.c" "timestamp.c" "variable.c" "modules.c" "strings.c"
"filesys.c" "builtins.c" "class.c" "cwd.c" "native.c" "md5.c"
"modules\set.c" "modules\path.c" "modules\regex.c" "modules\property-set.c"
"modules\sequence.c" "modules\order.c" "execnt.c" "filent.c" "pathnt.c"
"kernel32.lib" "advapi32.lib" "user32.lib"

[COPY] bin.ntx86\bjam.exe

        copy /Y "bin.ntx86\b2.exe" "bin.ntx86\bjam.exe" >NUL:

...updated 3 targets...

It seems that will give me the build commands, though it doesn't help me
with why the bootstrap process failed. I'll take the minor victory.


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at