Boost logo

Boost-Build :

Subject: Re: [Boost-build] [boost] [1.56] Sorry but no PDF doc build (build script has been broken)
From: Edward Diener (eldiener_at_[hidden])
Date: 2014-08-11 15:17:40

On 8/11/2014 7:24 AM, John Maddock wrote:
>>> Sorry folks, but as things stand there will be no PDF build of the docs
>>> for 1.56 as the build script appears to be hopelessly broken :-(
>>> Each time I fix one Boost.Build error it just leads to another, and
>>> frankly at present I have neither time nor inclination to keep tracking
>>> these down. If anyone wants to experience some pain then trying to
>>> invoke bjam in /doc/pdf/ will give you an idea of some of the issues.
>> You mean :
> Nope, I *think* that one is probably caused by you not having an FO
> processor registered in your user-config.jam

I have had:

using fop : "C:/Utilities/RenderX/XEP/xep.bat"
           : "C:/Program Files (x86)/Java/jre7"

for a long, long time and it has always worked before and still does
work for TTI when I create a PDF locally.

>, I get:
> error: at ..\..\libs\bind\doc\Jamfile.v2:6
> error: Attempt to redeclare already registered project id '/boost/doc'.
> error: Original project:
> error: Name: Jamfile<M:\data\boost\boost-1_56_0\doc>
> error: Module: Jamfile<M:\data\boost\boost-1_56_0\doc>
> error: Main id: /boost/doc
> error: File: ..\Jamfile.v2
> error: Location: ..
> error: New project:
> error: Module: Jamfile<M:\data\boost\boost-1_56_0\libs\bind\doc>
> error: File: ..\..\libs\bind\doc\Jamfile.v2
> error: Location: ../../libs/bind/doc
> Which I can workaround, but then I get the same error from
> Boost.Context, work around that one as well

I saw both of those also and locally "fixed" them.

> and then I get:
> M:/data/boost/boost-1_56_0/tools/build/src/build\targets.jam:397: in
> find-really
> *** argument error
> * rule ( id )
> * called with: ( )
> * missing argument id
> M:/data/boost/boost-1_56_0/tools/build/src/build\project.jam:600:see
> definition of rule '' being called
> M:/data/boost/boost-1_56_0/tools/build/src/build\targets.jam:457: in
> class_at_project-target.find
> M:/data/boost/boost-1_56_0/tools/build/src/build\targets.jam:841: in
> resolve-reference
> M:/data/boost/boost-1_56_0/tools/build/src/build\targets.jam:858: in
> targets.generate-from-reference
> M:/data/boost/boost-1_56_0/tools/build/src/build\targets.jam:1245: in
> generate-dependencies
> M:/data/boost/boost-1_56_0/tools/build/src/build\targets.jam:1302: in
> class_at_basic-target.generate
> M:/data/boost/boost-1_56_0/tools/build/src/build\targets.jam:757: in
> generate-really
> M:/data/boost/boost-1_56_0/tools/build/src/build\targets.jam:729: in
> class_at_main-target.generate
> M:/data/boost/boost-1_56_0/tools/build/src/build\targets.jam:272: in
> class_at_project-target.generate
> M:/data/boost/boost-1_56_0/tools/build/src\build-system.jam:707: in load
> M:\data\boost\boost-1_56_0\tools\build\src/kernel\modules.jam:289: in
> import
> M:\data\boost\boost-1_56_0\tools\build\src/kernel/bootstrap.jam:139: in
> boost-build
> M:\data\boost\boost-1_56_0\boost-build.jam:17: in module scope
> Which so freaking inscrutable that I'm pretty sure it's a Japanese
> translation of Klingon.
> I suspect the only proper solution is to have each library's Jamfile
> include an install rule to build the PDF and put it under dist/pdf. But
> with >60 libraries to patch and apparently the only way to submit a pull
> request for each (fork, clone, patch, test and submit), then do the same
> for master *and* develop branches, wait and hope that the maintainer is
> active and feeling favourable.... well you see my problem!

Of course.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at