Boost logo

Boost-Build :

Subject: Re: [Boost-build] Cannot get feature/subfeature not working with Oracle Solaris Studio C++ compiler
From: Edward Diener (eldiener_at_[hidden])
Date: 2015-03-26 15:28:40

On 3/26/2015 2:45 PM, Steven Watanabe wrote:
> On 03/26/2015 12:25 PM, Edward Diener wrote:
>> and b2 correctly invoked the correct version and used the
>> features/subfeature correctly to add -std=c++11 to the command line. So
>> your suggestion worked completely. But unfortunately the boost build jam
>> file automatically adds -library=stlport4 to the command line. When this
>> happens the compiler issues the message:
>> "CC: -library=stlport4 cannot be used with -std=c++11"
>> and the compilation fails.
>> I will look at the sun.jam file to see if I can change it locally for
>> 12.4. Would you look into making such a change permanently as I am
>> hardly an expert of Boost Build as you are ? Without the change in the
>> Boost Build jam file it is not possible to use -std=c++11 with the the
>> compiler.
> The problem is in Jamroot. I fixed it in develop,
> but it looks like the fix was never merged to master.

Do you mean jamroot.jam in Boost.Build ? I don't see your fix there.
Which jamroot do I need to get for the fix ?

>>> <snip>
>> The latest from Git. For boost build I tried 'master' first but then
>> switched to 'develop'.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at