Boost logo

Boost-Build :

Subject: Re: [Boost-build] Cygwin static build run from the Windows command line fails
From: Robert Ramey (ramey_at_[hidden])
Date: 2016-03-14 01:41:21

On 2/23/16 7:51 AM, Beman Dawes wrote:
> The problem is that b2 invokes ar.exe and ranlib.exe in
> "/usr/x86_64-pc-cygwin/bin" rather than "c:/cygwin64/bin"
> Compiles and shared builds work OK because user-config.jam has this entry:
> using gcc : c++03 : c:/cygwin64/bin/g++ : <cxxflags>"-Wconversion" ;
> As a work around, I've created a symlink from
> "c:/usr/x86_64-pc-cygwin/bin" to "c:/cygwin64/bin", and that works fine.
> But it would save a lot of aggravation if b2 just worked without the
> workaround. Incidentally, the msvc toolset does not have this problem.

Did the problems with cygwin ever get solved?

I updated from the master and rebuilt boost build. Things seem to run
OK until it's time to actually build the tests - at which point the
compile fails because of a path name problem. This is the same issue as
before so I assume it's never been actually fixed.

I tried building under windows command shell. The build gives out of
number of messages which mention gcc so it's not clear to me that it's
really building with msvc which is on the machine. In any case it can't
build the tests under the command shell.

FYI - when using boost build under windows xp, I'm sort of surprised
that b2 headers isn't mentioned in the "getting started". I followed
the instructions as written.

Note that I'm only doing this because I can't see the error messages
with the msvc builds of the serialization library which are truncated.

Can't we get things working as advertised? This kind of stuff costs me
a lot of time I don't have.

Robert Ramey

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at