Boost logo

Boost-Build :

Subject: Re: [Boost-build] gcc barfs with ERROR: rule "qt.init" unknown in module "toolset".
From: Francis (Grizzly) Smit (grizzly_at_[hidden])
Date: 2016-05-07 10:22:26

On 07/05/16 23:08, Vladimir Prus wrote:
> On 07/05/2016 15:37, Francis (Grizzly) Smit wrote:
>> I'm trying to install boost-build from git and I get the following error
>> sudo ./b2 install
>> /home/grizzlysmit/Downloads/boost/build/src/build/toolset.jam:43: in
>> toolset.using
>> ERROR: rule "qt.init" unknown in module "toolset".
>> /home/grizzlysmit/Downloads/boost/build/src/build/project.jam:1052:
>> in using
>> /home/grizzlysmit/user-config.jam:86: in modules.load
>> /home/grizzlysmit/Downloads/boost/build/src/build-system.jam:249: in
>> load-config
>> /home/grizzlysmit/Downloads/boost/build/src/build-system.jam:389: in
>> load-configuration-files
>> /home/grizzlysmit/Downloads/boost/build/src/build-system.jam:524: in
>> load
>> /home/grizzlysmit/Downloads/boost/build/src/kernel/modules.jam:295:
>> in import
>> /home/grizzlysmit/Downloads/boost/build/src/kernel/bootstrap.jam:139:
>> in boost-build
>> /home/grizzlysmit/Downloads/boost/build/boost-build.jam:8: in module
>> scope
>> what gives
> Francis,
> this is quite strange. Do you have any of
> /home/grizzlysmit/Downloads/boost/build/src/tools/qt.jam
> /home/grizzlysmit/Downloads/boost/build/src/tools/qt5.jam
I have both of these
> Can you modify /home/grizzlysmit/user-config.jam:86 to have
> using qt5 ;
> as opposed to
> using qt ;
> ?
changing to qt5 worked but then it couldn't find qmake
so I changed it to
using qt5 : /usr/lib/x86_64-linux-gnu/qt5 ;

that solved that thank you

I am on ubuntu 16.04

now I get

gcc.compile.c++ bin/gcc/debug/main.o
/bin/sh: 2: -ftemplate-depth-128: not found

       -ftemplate-depth-128 -O0 -fno-inline -Wall -g -fPIC -Wall
-std=c++1z -c -o "bin/gcc/debug/main.o" "main.cpp"

...failed gcc.compile.c++ bin/gcc/debug/main.o...

ah fixed that was calling b2 toolset=clang toolset=gcc

changed to
b2 toolset=gcc

and it worked no mention of -ftemplate-depth-128 now
the interesting thing is clang doesn't like it either but it will
compile with it

    .~.     In my life God comes first....
    /V\         but Linux is pretty high after that :-D
   /( )\    Francis (Grizzly) Smit
Version: 3.1
GM/CS/H/P/S/IT/L d- s+:+ a++ C++++ UL++++$ P+++ L+++$ E--- W+++
N w--- M-- V-- PE- PGP t+ 5-- X-- R- tv b++++ DI(+) D-
G e++ h+ y? r% z---

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at