Boost logo

Boost-Build :

Subject: Re: [Boost-build] date_time develop branch test failures
From: Tal Lancaster (tal.lancaster_at_[hidden])
Date: 2017-06-05 14:00:05

Just to close out the loop.

I am using MacOS, Xcode 8.2.1.

The issue worked itself out. At the time, I may have been mixing develop and master branches in my boost directory. But after updating with the latest develop branch for config the errors went away and all of the tests compile (and pass).

> On May 29, 2017, at 11:08 AM, Edward Diener via Boost-build <boost-build_at_[hidden]> wrote:
> On 5/29/2017 12:36 PM, Tal Lancaster via Boost-build wrote:
>> I am seeing a bunch of errors when I run b2 in the date_time test directory:
>> ../../../boost/preprocessor/iteration/detail/iter/forward1.hpp:47:18: fatal error: 'boost/utility/detail/result_of_iterate.hpp' file not found
>> # include BOOST_PP_FILENAME_1
>> ^
>> ../../../boost/preprocessor/iteration/detail/iter/forward1.hpp:27:56: note: expanded from macro 'BOOST_PP_FILENAME_1'
>> ^
>> ../../../boost/utility/result_of.hpp:201:68: note: expanded from macro 'BOOST_PP_ITERATION_PARAMS_1'
>> #define BOOST_PP_ITERATION_PARAMS_1 (3,(0,BOOST_RESULT_OF_NUM_ARGS,<boost/utility/detail/result_of_iterate.hpp>))
> What compiler under what OS are you using ? For what test do your errors show ? Did you look at the 'develop' regression tests for date_time at, to see if the errors you are seeing are duplicated there ?
>> Tal
> _______________________________________________
> Unsubscribe & other changes:

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at