Boost logo

Boost-Build :

Subject: [Boost-build] Missing libs?
From: David Bergman (davidrbergman_at_[hidden])
Date: 2017-11-15 14:38:20

I recently posted about getting the boost libraries to build.  This issue is solved but I've run into another.I'm trying to use gnuplot, and gnuplot-iostream to develop a GUI for simulation s/w and the gp-iostream uses boost::iostream.
A simple example pulled form the gp-io site gives link errors, 7 unresolved externals.  An example of one is,

error LNK2019: unresolved external symbol "public: void __thiscall boost::iostreams::file_descriptor::close(void)" (?close_at_file_descriptor_at_iostreams@boost@@QAEXXZ) referenced in function "public: static void __cdecl boost::iostreams::detail::close_impl<struct boost::iostreams::closable_tag>::close<class boost::iostreams::file_descriptor_sink>(class boost::iostreams::file_descriptor_sink &,int)" (??$close_at_Vfile_descriptor_sink_at_iostreams@boost@@@?$close_impl_at_Uclosable_tag_at_iostreams@boost@@@detail_at_iostreams@boost@@SAXAAVfile_descriptor_sink_at_23@H_at_Z)

In the past with other libraries, similar errors were fixable (ensuring correct path is set in the IDE, #includes are in correct order, etc).  I'm using VS 2017 and the "intellisense" isn't showing any issues.  I have added paths for includes and linker libraries the same way I've done in the past with other libs and they've worked. 

I'm reaching out to the boost community to see if anyone has had this issue with a similar combination of libraries.

Thanks in advance for your help.David

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at