Boost logo

Boost-Build :

Subject: Re: [Boost-build] using toolset vs toolset=
From: Alexander Arhipenko (arhipjan_at_[hidden])
Date: 2018-06-02 13:34:43

Hi Steven,

On Wed, May 30, 2018 at 3:30 PM, Steven Watanabe via Boost-build
<boost-build_at_[hidden]> wrote:
> [snip]
>> WARNING: Unable to construct sample/sample of type EXE with these properties:
>> <snip>
>> --debug-generators did not provide insights to me yet.
>> Do you have an idea what causes the error and how to fix it?
> Try --debug-configuration as well. Also, this
> may be related:
> I do notice that the clang version is not listed in
> the properties.

Thank you for reply.
I have noticed your comment in
> I was testing at $BOOST_ROOT.
> The reason it worked for me is that the top level target stage target is an alias,
> so there's an extra expansion before it gets to anything that actually needs building.

... and added project definition to my Jamroot.jam that was previously empty:
project cvboost : default-build debug;

That solved the problem however I am not 100% sure why.
For your information, difference in properties (site-config.jam vs toolset=)
before making changes to Jamroot was:
<toolset-clang:platform>darwin <toolset-clang:version>4.2.1
The latter 2 was added when invoking b2 with toolset=clang.


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at