Boost logo

Boost-Build :

From: Maarten Verhage (m_r_verhage_at_[hidden])
Date: 2019-07-30 14:00:17

Dear Boost.Build experts,

I do have Boost 1.69 and was able to build boost from the sources with
Mingw-w64 gcc 8.1 on Windows 7. That was for boost itself, but now I need to
build the tests for the Boost library Spirit (the parser). I cannot get this
to work. To be more precise it's the Github develop version of that library.

My Boost.Build version is 2018.02-git.

According to Boost.Build documentation paragraph 3.3 Configuration, the
option "b2 --debug-configuration" gives info how my is

In the folder <boost-build>\example\hello the output of
 "b2 --debug-configuration" looks fine. So boost build seems to be setup

But when I run from the folder <boost-spirit-develop>\test
"b2 --debug-configuration" the output contains:
error: Could not find parent for project at '.'.

So in the folder <boost-spirit-develop>\test I rename Jamfile to
Jamroot.jam. Now with "b2 --debug-configuration" I get: output.txt
(attachtment of this email)

Also when I try to build the tests I get the same error messages, strarting
config.jam: No such file or directory

How do I solve this?

Best regards,
Maarten Verhage

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at