Boost logo

Boost-Build :

From: Maarten Verhage (m_r_verhage_at_[hidden])
Date: 2019-07-31 17:06:28

Hi Edward,

>> Here are the things I think you need to do to do this:
>> 1) Get the latest Boost from Github into a directory and then run these
>> comamnds from that directory:
>> 2) git checkout develop
>> 3) git pull
>> 4) get submodule update --init
>> 5) git submodule foreach --recursive git checkout develop
>> 6) git submodule foreach --recursive git pull
>> 7) ./bootstrap.bat to create the latest b2
>> 8) ./b2 headers
>> 10) cd to the Spirit test directory
>> 11) ../../../b2 toolset=gcc-8.1 etc.

I prefered to continue using boost 1.69 as the main library. But I did a
Github clone of
just the Boost-build develop library and did the above steps on that.

>> The last step needs an appropriate entry for the gcc-8.1 toolset in your
>> user-config.jam. My user-config.jam entry for running gcc-8.1 in 32-bit
>> mode is:

The mingw-w64 library I use is x86_64-8.1.0-release-win32-seh-rt_v6-rev0.
In the bootstrap build of boost-build I switched temporarily to the
posix-seh variant (this has to do with thread support). But the build of b2
was succesful.

I do have a problem with the last part of your instructions. The only
user-config.jam file is located in the folder <path-to-boost-build>\example,
do you mean I use that one somehow? Additionally for the mingw-w64 version I
use I don't have a cp_gcc81.bat file.

If I run b2 now in the spirit\test folder I still get the:
config.jam: No such file of directory
followed be the same stuff as output.txt in the attachment of my first post

Are you willing to explain a bit more on what is happening? Then you can
give me a chance to apply my own judgement as how to attack this problem. As
I'm now under the impression that this new b2.exe file is not solving

> using gcc : 8.1 :
> "$(TSE_BATCH_DRIVE)/programming/bat/cp_gcc81.bat" :
> <cxxflags>-Wno-unused-local-typedefs
> <cxxflags>-ftrack-macro-expansion=0
> <cxxflags>-Wno-unused-variable
> <cxxflags>-D_GLIBCXX_USE_CXX11_ABI=1
> <root>"$(TSE_MINGW64_DRIVE)/Utilities/mingw-w64/i686-8.1.0-posix-dwarf-rt_v6-rev0/mingw32"
> ;

 Regards, Maarten

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at