I am compiling boost.python libraries by following the procedure given at

I first configure the build and installation using bootstrap.sh script

$ ./bootstrap.sh --with-python=/usr/bin/python2.5 --with-libraries=python --prefix=~/work/boost/setup/boost_1_39_0/mybuild

Here are the contents of project-config.jam fie as generated by the script.

    # Boost.Build Configuration
    # Automatically generated by bootstrap.sh

    import option ;
    import feature ;

    # Compiler configuration. This definition will be used unless
    # you already have defined some toolsets in your user-config.jam
    # file.
    if ! gcc in [ feature.values <toolset> ]
        using gcc ;

    project : default-build <toolset>gcc ;

    # Python configuration
    using python : 2.5 : /usr ;

    # List of --with-<library> and --without-<library>
    # options. If left empty, all libraries will be built.
    # Options specified on the command line completely
    # override this variable.
    libraries =  --with-python ;

    # These settings are equivivalent to corresponding command-line
    # options.
    option.set prefix : ~/work/boost/setup/boost_1_39_0/mybuild ;
    option.set exec-prefix : ~/work/boost/setup/boost_1_39_0/mybuild ;
    option.set libdir : /lib ;
    option.set includedir : ~/work/boost/setup/boost_1_39_0/mybuild/include ;
The output of bootstrap.sh script instructs me to run ./bjam to build while instructions at the above link say to run ./bjam install
Anyways, I tried both the options but every time I get the same error

    Class top-level-target already defined

My system configuration as reported by uname -a is,
Linux prakt01 #1 SMP Mon Mar 23 23:08:10 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

I searched the forums, but this error seems to never be discussed. I am stuck, please help!

Best regards,
Aamir Ahmed Khan