By the way.. Thanks for reporting on your experiences. Getting first time impressions of build usage it some we wish had more of...

On Sun, Nov 16, 2014 at 8:56 PM, Michael Rolle <> wrote:
I was trying to build something when I didn't have my environment set up correctly.  Basically there was a problem initializing the boot system, which the bjam command reported.  I tried 'bjam --help', and I got the same error message.

I'm guessing it was complaining that it couldn't find the build system? Could you post the commands you followed to get this stage?
If there is no jamfile, the --help and --version options work fine.  But in the case where there is a jamfile or jamroot present, bjam tries to initialize the build system first, before checking for --help or --version.  These command line arguments are supposed to only print the corresponding information and nothing else.
So what I would like you to fix is for bjam to check these options on the command line and then exit, before trying to perform the build.

Unfortunately it's not possible. All the "--[ooption]" arguments are parsed after the base b2 is loaded. I.e. they are parsed as part of the BBv2 build system which is external to the executable. And hence it needs to find and load the build system (as opposed to just the interpreter core) before handling those. But since you didn't get that far all it can say is that it failed to find the build system. Note, the single dash options like "-h" and "-v" still work.

-- Rene Rivera
-- Grafik - Don't Assume Anything
-- Robot Dreams -
-- rrivera/ (msn) - grafikrobot/aim,yahoo,skype,efnet,gmail