Thanks for the help.  Though I will say that the Visual Studio Project Property Pages | Linker |
General | Additional Library Directories property is actually set to the lib directory.  I may have the dir name wrong and will check that.
I will also look into your second comment.  This is a little beyond my level of sophistication. 

In the event that these issues do not resolve I wonder if there could be a conflict with another "include" dir.  For example, I want to use the traditional boost header files for math functions and have that path set in ... | VC++ Directories | Include Directories.  Also, since I'm trying to use gp-io with this might there be a conflict with that?


From: Robert via Boost-build <>
Cc: Robert <>
Sent: Wednesday, November 15, 2017 10:35 AM
Subject: Re: [Boost-build] Missing libs?

On 11/15/2017 8:38 AM, David Bergman via Boost-build wrote:
> I recently posted about getting the boost libraries to build.  This
> issue is solved but I've run into another.
> I'm trying to use gnuplot, and gnuplot-iostream to develop a GUI for
> simulation s/w and the gp-iostream uses boost::iostream.
> A simple example pulled form the gp-io site gives link errors, 7
> unresolved externals.  An example of one is,
> error LNK2019: unresolved external symbol "public: void __thiscall
> boost::iostreams::file_descriptor::close(void)"
> (?close@file_descriptor@iostreams@boost@@QAEXXZ) referenced in function
> "public: static void __cdecl boost::iostreams::detail::close_impl<struct
> boost::iostreams::closable_tag>::close<class
> boost::iostreams::file_descriptor_sink>(class
> boost::iostreams::file_descriptor_sink &,int)"
> (??$close@Vfile_descriptor_sink@iostreams@boost@@@?$close_impl@Uclosable_tag@iostreams@boost@@@detail@iostreams@boost@@SAXAAVfile_descriptor_sink@23@H@Z)
> In the past with other libraries, similar errors were fixable (ensuring
> correct path is set in the IDE, #includes are in correct order, etc). 
> I'm using VS 2017 and the "intellisense" isn't showing any issues.  I
> have added paths for includes and linker libraries the same way I've
> done in the past with other libs and they've worked.
> I'm reaching out to the boost community to see if anyone has had this
> issue with a similar combination of libraries.

It looks like the Visual Studio Project Property Pages | Linker |
General | Additional Library Directories property is not set.  If you
are building for both 32-bit and 64-bit versions, you will have to have
different paths to the Boost library files.  There is not yet a bit size
in the library file names.  For example, on my various projects, I have
all 32-bit library files in C:\Boost\lib.  I have all 64-bit library
files in C:\Boost\lib\x64.  When the Visual Studio project's 32-bit
Additional Library Directories property is user set, the ending string
has a special automatically added value:


Keep in mind that the Visual Studio Property Pages dialog drop down
combination selection is key to knowing which configuration combination
is modified.  The dialog combo boxes do not synchronize with the current
selection in the editing environment.


> Thanks in advance for your help.
> David
> _______________________________________________
> Unsubscribe & other changes:


Unsubscribe & other changes: