Boost logo

Boost-Commit :

From: nesotto_at_[hidden]
Date: 2007-10-23 15:06:40


Author: nesotto
Date: 2007-10-23 15:06:39 EDT (Tue, 23 Oct 2007)
New Revision: 40371
URL: http://svn.boost.org/trac/boost/changeset/40371

Log:
change names of ADL functions back to 1.34 names ... the old names have been in use for too long so let's not break code that depends on them
Text files modified:
   trunk/libs/range/test/extension_mechanism.cpp | 8 ++++----
   1 files changed, 4 insertions(+), 4 deletions(-)

Modified: trunk/libs/range/test/extension_mechanism.cpp
==============================================================================
--- trunk/libs/range/test/extension_mechanism.cpp (original)
+++ trunk/libs/range/test/extension_mechanism.cpp 2007-10-23 15:06:39 EDT (Tue, 23 Oct 2007)
@@ -57,24 +57,24 @@
         // to be defined because X defines the proper set of
         // nested types.
         //
- inline X::iterator range_begin( X& x )
+ inline X::iterator boost_range_begin( X& x )
         {
                 return x.vec.begin();
         }
 
 
- inline X::const_iterator range_begin( const X& x )
+ inline X::const_iterator boost_range_begin( const X& x )
         {
                 return x.vec.begin();
         }
 
 
- inline X::iterator range_end( X& x )
+ inline X::iterator boost_range_end( X& x )
         {
                 return x.vec.end();
         }
 
- inline X::const_iterator range_end( const X& x )
+ inline X::const_iterator boost_range_end( const X& x )
         {
                 return x.vec.end();
         }


Boost-Commit list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk