|
Boost-Commit : |
Subject: [Boost-commit] svn:boost r50174 - trunk/tools/build/v2/tools
From: ghost_at_[hidden]
Date: 2008-12-07 03:55:44
Author: vladimir_prus
Date: 2008-12-07 03:55:43 EST (Sun, 07 Dec 2008)
New Revision: 50174
URL: http://svn.boost.org/trac/boost/changeset/50174
Log:
Use 'common.mkdir' as the name of the action shown to user.
There's no need to include 'quick-fix' in that text :-)
Text files modified:
trunk/tools/build/v2/tools/common.jam | 35 ++++++++++++++++-------------------
1 files changed, 16 insertions(+), 19 deletions(-)
Modified: trunk/tools/build/v2/tools/common.jam
==============================================================================
--- trunk/tools/build/v2/tools/common.jam (original)
+++ trunk/tools/build/v2/tools/common.jam 2008-12-07 03:55:43 EST (Sun, 07 Dec 2008)
@@ -596,14 +596,7 @@
$(<)-mkdir = true ;
# Schedule the mkdir build action.
- if [ os.name ] = NT
- {
- MkDir1-quick-fix-for-windows $(<) ;
- }
- else
- {
- MkDir1-quick-fix-for-unix $(<) ;
- }
+ common.mkdir $(<) ;
# Prepare a Jam 'dirs' target that can be used to make the build only
# construct all the target directories.
@@ -638,27 +631,31 @@
}
-actions MkDir1
-{
- mkdir "$(<)"
-}
+#actions MkDir1
+#{
+# mkdir "$(<)"
+#}
-
-# (todo)
# The following quick-fix actions should be replaced using the original MkDir1
# action once Boost Jam gets updated to correctly detect different paths leading
# up to the same filesystem target and triggers their build action only once.
# (todo) (04.07.2008.) (Jurko)
-actions MkDir1-quick-fix-for-unix
+
+if [ os.name ] = NT
{
- mkdir -p "$(<)"
+ actions mkdir
+ {
+ if not exist "$(<)\\" mkdir "$(<)"
+ }
}
-actions MkDir1-quick-fix-for-windows
+else
{
- if not exist "$(<)\\" mkdir "$(<)"
+ actions mkdir
+ {
+ mkdir -p "$(<)"
+ }
}
-
actions piecemeal together existing Clean
{
$(RM) "$(>)"
Boost-Commit list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk