Boost logo

Boost-Commit :

Subject: [Boost-commit] svn:boost r64394 - in sandbox/SOC/2010/bit_masks: . boost/integer/detail/bft
From: bbartmanboost_at_[hidden]
Date: 2010-07-27 13:53:05


Author: bbartman
Date: 2010-07-27 13:53:04 EDT (Tue, 27 Jul 2010)
New Revision: 64394
URL: http://svn.boost.org/trac/boost/changeset/64394

Log:
changing the name of one of the implementation files from bft_element to bitfield_element
Added:
   sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/bitfield_element.hpp
      - copied unchanged from r64390, /sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/bft_element.hpp
Removed:
   sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/bft_element.hpp
Text files modified:
   sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/bitfield_tuple_impl.hpp | 2 +-
   sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/name_lookup.hpp | 2 +-
   sandbox/SOC/2010/bit_masks/notes.txt | 22 +++++-----------------
   3 files changed, 7 insertions(+), 19 deletions(-)

Deleted: sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/bft_element.hpp
==============================================================================
--- sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/bft_element.hpp 2010-07-27 13:53:04 EDT (Tue, 27 Jul 2010)
+++ (empty file)
@@ -1,44 +0,0 @@
-// Copyright 2010 Brian Bartman.
-// Distributed under the Boost Software License, Version 1.0.
-// (See accompanying file LICENSE_1_0.txt or copy at
-// http://www.boost.org/LICENSE_1_0.txt)
-
-#ifndef BOOST_BITFIELD_TUPLE_BFT_ELEMENT_HPP
-#define BOOST_BITFIELD_TUPLE_BFT_ELEMENT_HPP
-#include <boost/mpl/void.hpp>
-
-
-namespace boost { namespace bitfields { namespace detail {
-
-/** This is the type which sits inside the mpl vector type.
- * This has all information for constructing a bitfield.
- */
-template < typename ReturnType,
- typename NameType,
- typename Offset,
- typename FieldWidth,
- typename Mask = mpl::void_,
- typename Policy = mpl::void_
->
-struct bitfield_element {
- typedef ReturnType return_type;
- typedef NameType name_type;
- typedef Offset offset;
- typedef FieldWidth field_width;
-
- typedef Mask mask;
- typedef Policy policy;
- typedef bitfield_element<
- return_type,
- name_type,
- offset,
- field_width,
- mask,
- policy
- > type;
-};
-
-
-}}} // end boost::detail
-
-#endif

Modified: sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/bitfield_tuple_impl.hpp
==============================================================================
--- sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/bitfield_tuple_impl.hpp (original)
+++ sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/bitfield_tuple_impl.hpp 2010-07-27 13:53:04 EDT (Tue, 27 Jul 2010)
@@ -18,7 +18,7 @@
 #include <boost/static_assert.hpp>
 
 // implementation header files.
-#include <boost/integer/detail/bft/bft_element.hpp>
+#include <boost/integer/detail/bft/bitfield_element.hpp>
 #include <boost/integer/detail/bft/arg_parse_impl.hpp>
 #include <boost/integer/detail/bft/deduce_storage.hpp>
 

Modified: sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/name_lookup.hpp
==============================================================================
--- sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/name_lookup.hpp (original)
+++ sandbox/SOC/2010/bit_masks/boost/integer/detail/bft/name_lookup.hpp 2010-07-27 13:53:04 EDT (Tue, 27 Jul 2010)
@@ -5,7 +5,7 @@
 
 #ifndef BOOST_BITFIELD_TUPLE_NAME_LOCATER_HPP
 #define BOOST_BITFIELD_TUPLE_NAME_LOCATER_HPP
-#include <boost/integer/detail/bft/bft_element.hpp>
+#include <boost/integer/detail/bft/bitfield_element.hpp>
 #include <boost/mpl/find_if.hpp>
 #include <boost/type_traits/is_same.hpp>
 

Modified: sandbox/SOC/2010/bit_masks/notes.txt
==============================================================================
--- sandbox/SOC/2010/bit_masks/notes.txt (original)
+++ sandbox/SOC/2010/bit_masks/notes.txt 2010-07-27 13:53:04 EDT (Tue, 27 Jul 2010)
@@ -4,8 +4,6 @@
 1) create element metafunction for returning the return type of a field.
 2) Create a get free function which takes a bitfield_tuple.
 
-
-
 5) Documentation for align -
     "Ensures the offset of the next bit field is divisible by the supplied value."
 
@@ -14,17 +12,8 @@
 List of TODO's throughout the bitfield_tuple
 
 1) template_expansion_macros.hpp
- b) MAYBE: Rename some of the internal use only macros so they don't
- get confused with macros for external use.
-
-
 2) reference_builder.hpp
-
-
 3) proxy_reference_policy.hpp
- a) Create the custom member.
- b) Create documentation for how to create your own policy.
- c) This may need additional documentation however it looks good currently.
 
 
 4) pointer_parsing_meta_functions.hpp
@@ -43,9 +32,7 @@
 
 
 10) arg_parse_impl.hpp
- b) Implement the specialization for custom members.
- I ) This could be more of a pain, however it seems quite simple
- after implementing the pointer stuff.
+
 
 12) bitfield_iterator.hpp - Fusion Extension
     A) Add OR remove const functions. Fusion may be a non const only
@@ -56,7 +43,7 @@
 14) bitfield_tuple.hpp
 15) Remove old pointer plus bits stuff
 16) interface_meta_functions.hpp
- a) Move all of the meta functions in side of time into namespace bitfields
+
 
 Test file review
 1) variadic_sequence_testing.cpp
@@ -67,8 +54,6 @@
         assured that the limit is working correctly.
     d) remove testing from the end of file name.
 
-2) to_string_testing.cpp
- a) Remove this its not part of bitfield_tuple any more.
 
 3) template_expansion_marco_test.cpp
     a) Make this an actual test to make sure that everything is correctly
@@ -215,5 +200,8 @@
 
 *) Update documentation for filler -> padding
 *) update documentation for bit_align -> align
+*) Create documentation for how to create your own policy.
+*) proxy_reference_policy may need additional documentation however it looks
+ good currently.
 --------------------------------------------------------------------------------
 


Boost-Commit list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk