|
Boost-Commit : |
Subject: [Boost-commit] svn:boost r75927 - trunk/boost/iostreams/detail
From: dnljms_at_[hidden]
Date: 2011-12-12 18:03:07
Author: danieljames
Date: 2011-12-12 18:03:07 EST (Mon, 12 Dec 2011)
New Revision: 75927
URL: http://svn.boost.org/trac/boost/changeset/75927
Log:
Iostreams: Rename `check` to avoid apple macro.
Safe to rename this one as it's in detail.
Text files modified:
trunk/boost/iostreams/detail/is_dereferenceable.hpp | 6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)
Modified: trunk/boost/iostreams/detail/is_dereferenceable.hpp
==============================================================================
--- trunk/boost/iostreams/detail/is_dereferenceable.hpp (original)
+++ trunk/boost/iostreams/detail/is_dereferenceable.hpp 2011-12-12 18:03:07 EST (Mon, 12 Dec 2011)
@@ -49,10 +49,10 @@
# endif
// two check overloads help us identify which operator++ was picked
- char (& check BOOST_PREVENT_MACRO_SUBSTITUTION(tag) )[2];
+ char (& check_increment(tag) )[2];
template <class T>
- char check BOOST_PREVENT_MACRO_SUBSTITUTION(T const&);
+ char check_increment(T const&);
template <class T>
struct impl
@@ -61,7 +61,7 @@
BOOST_STATIC_CONSTANT(
bool
- , value = sizeof(is_dereferenceable_::check BOOST_PREVENT_MACRO_SUBSTITUTION(BOOST_comma(*x,0))) == 1
+ , value = sizeof(is_dereferenceable_::check_increment(BOOST_comma(*x,0))) == 1
);
};
}
Boost-Commit list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk