[Boost-docs] [quickbook] Escape doesn't escape?

Subject: [Boost-docs] [quickbook] Escape doesn't escape?
From: Rene Rivera (grafikrobot_at_[hidden])
Date: 2011-10-28 04:13:35

First.. Interesting conversations around here recently :-)

Second.. Back to my desire to do some more literate programming and
documentation management..

While doing my quickbook changes I ran into one problem. It seems that
even though the documentation make the general claim that the backslash
("\") can be used to escape any character, and specifically mentions "["
and "]", it doesn't actually seem to be generally applicable. for
example trying to escape in the argument to the "import" doesn't work at
all. Which has two effects:

1. One can never have files with "]" in them as it terminates the import
invocation in the middle of the path with an illegal path since it now
ends with "\".

2. It also makes it impossible to use a regex expression for the path.
Which is what I was actually doing when I ran into this.

Any ideas on what can be done? Is this a general problem of block
argument parsing? Or is it specific to import like things?

-- Grafik - Don't Assume Anything
-- Redshift Software, Inc. - http://redshift-software.com
-- rrivera/acm.org (msn) - grafik/redshift-software.com
-- 102708583/icq - grafikrobot/aim,yahoo,skype,efnet,gmail

This archive was generated by hypermail 2.1.7 : 2017-11-11 08:50:41 UTC