Boost logo

Boost :

Subject: Re: core in value_core and reference_core
From: Mateusz Loskot (mateusz_at_[hidden])
Date: 2019-03-01 23:38:58

Thanks Christian, I'll take it.

I have ported the value_core and reference_core from the legacy tests
to new modular tests, renamed as pixel_value and pixel_reference
whth the old names as aliases to make it easier to find where it comes from:

Since the test/ directotry contains tests of the core features only,
the `core` preffix/suffix is superfluous. Thus, I renamed those xxx_core
with more descriptive names. (Yeah, I'm anal about clear naming :))


On 19-02-28 14:39:33, Christian Henning wrote:
>I think "core" just means gil only without any extensions. I might be
>On Thu, Feb 28, 2019 at 2:37 PM Mateusz Łoskot <mateusz_at_[hidden]> wrote:
>> Hi,
>> In two legacy tests, channel.cpp [1] and pixel.cpp [2], there are so called
>> 'core' classes defined, with this comment in [1]:
>> "// Different core classes depending on the different types of..." [1]
>> I'm (as not a native speaker) not clear what is the semantic of the word
>> 'core'.
>> Is this the same as test fixture? Or, an archetype, prime example, a mold?
>> I have a feeling that provenance of the 'core' name is historic like in
>> 'core
>> dump' [3]. There must be a good reason why the original GIL authors chose
>> to use
>> 'core' in those classes.
>> [1]
>> [2]
>> [3]
>> Best regards,
>> --
>> Mateusz Loskot,
>> --
>> Boost-gil mailing list
>> Boost-gil_at_[hidden]
>Boost-gil mailing list

Mateusz Loskot,

Boost list run by Boost-Gil-Owners