Boost logo

Boost Testing :

Subject: Re: [Boost-testing] New Windows Runner - reset hard error
From: Niklas Angare (li51ckf02_at_[hidden])
Date: 2014-05-29 15:35:25

"Tom Kent" <lists_at_[hidden]> wrote:
> I'm trying to setup a new regression test runner on a windows (virtual)
> machine.
> It appears the script is having a problem with
> # Executing GIT command: D:\local\teeks99-06\a\boost_root> git submodule
> foreach
> ""git reset --quiet --hard; git clean -fxd""
> Entering 'libs/accumulators'
> error: unknown option `hard;'
> usage: git reset [--mixed | --soft | --hard | --merge | --keep] [-q]
> [<commit>]

I just tried with git 1.8.3 on Windows and it worked. I then upgraded to git
1.9.2 and got the same error as you did.

Removing the double quotes from the relevant line in works for
me with both git 1.8.3 and 1.9.2 on Windows and git 1.9.2 on QNX. The line
then reads as follows:
self.git_command( 'submodule foreach', 'git reset --quiet --hard; git
clean -fxd')

I've attached a patch.

Add --skip-script-download to the command line to try with a patched


Niklas Angare

Boost-testing list run by mbergal at