Boost logo

Boost Testing :

Subject: Re: [Boost-testing] Question about posting boost test results to boost community
From: Cao, Bin (Bin.Cao_at_[hidden])
Date: 2019-04-25 03:10:38

Thanks Rene Rivera for the reply.

Actually I have tried to upload for develop with the same command, but nothing was shown up on the develop summary page.

I noticed in the issues page, it says “Failure on a newly added test/compiler. Unexpected failure.” for <toolset>.
Does that mean my toolset name “clang-vxworks-4.0.1” is not correct?

Does there have any place to show what happened to my uploadings, and the reasons why my uploadings failed?


From: Rene Rivera [mailto:grafikrobot_at_[hidden]]
Sent: Wednesday, April 24, 2019 7:52 PM
To: Running Boost regression tests
Cc: Cao, Bin
Subject: Re: [Boost-testing] Question about posting boost test results to boost community

On Wed, Apr 24, 2019 at 6:00 AM Cao, Bin via Boost-Testing <boost-testing_at_[hidden]<mailto:boost-testing_at_[hidden]>> wrote:
Thanks Steven Watanabe for the answer.

We are running the tests by directly calling b2 in a local wrapper, rather than calling
So, does that make sense for us to just upload the test logs using

I tried the following command, it says "Uploading log archive ... to master". But I did not see my test results on the summary page after several hours. was manually created which only includes the attached log file.

$ python --runner=BinCaoWR --toolsets=clang-vxworks-4.0.1 --tag=master --platform=vxWorks --comment=comment.html upload-logs
# Running regressions in /opt/boost/Logs/boost_simics_nightly/20190421200812/any/xlnx_zynqmp_platform_smp/j32.xlnx_zynqmp_xlnxzcu102_default.true.llvm.vsbdir.lp64smp...
# Creating regression scripts at /opt/boost/Logs/boost_simics_nightly/20190421200812/any/xlnx_zynqmp_platform_smp/j32.xlnx_zynqmp_xlnxzcu102_default.true.llvm.vsbdir.lp64smp/boost_regression_src...
# Downloading regression scripts from
# Uploading log archive "/opt/boost/Logs/boost_simics_nightly/20190421200812/any/xlnx_zynqmp_platform_smp/j32.xlnx_zynqmp_xlnxzcu102_default.true.llvm.vsbdir.lp64smp/results/" to master

Is there anything wrong in my command, or any restriction on the test log format/content, etc?

What shows up in master is whitelisted. You need to test and upload for develop before being able to do the same for master.

-- Rene Rivera
-- Grafik - Don't Assume Anything
-- Robot Dreams ->

Boost-testing list run by mbergal at