Boost logo

Boost Users :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-06-18 21:01:33

"Virginia Volk" <vvolk_at_[hidden]> wrote in message
> Thank you for the help so far. Ok, I run the following line:
> bjam_solaris -a "-sTOOLS=gcc-stlport" "-sBUILD=debug release"
> "-sSTLPORT_ROOT=/core/elements/cots/stlport-4.5.3"
> where:
> -bjam_solaris - Boost.Jam executable for SUN Solaris
> -boost 1.28.0
> -stlport 4.5.3
> -gcc 2.95.3
> I still get the following errors (only first part reprinted here for
> size):
> ---------------------------------------------------------------------
> skipping Boost.Python library build

are you trying to build Boost.Python? If so, follow the configuration
instructions at Otherwise you can
ignore this part.

> ---------------------------------------------------------------------
> ...found 818 targets...
> ...updating 103 targets...
> MkDir1 libs/regex/build/bin-stage
> MkDir1 libs/regex/build/bin
> MkDir1 libs/regex/build/bin/libboost_regex.a
> MkDir1 libs/regex/build/bin/libboost_regex.a/gcc-stlport
> MkDir1 libs/regex/build/bin/libboost_regex.a/gcc-stlport/debug
> MkDir1
> libs/regex/build/bin/libboost_regex.a/gcc-stlport/debug/runtime-link-dyn
> amic
> gcc-C++-action
> libs/regex/build/bin/libboost_regex.a/gcc-stlport/debug/runtime-link-dyn
> amic/c_regex_traits.o
> In file included from
> /core/elements/cots/stlport-4.5.3/stlport/stl/_algobase.h:51,
> from
> /core/elements/cots/stlport-4.5.3/stlport/stl/_list.h:34,
> from /core/elements/cots/stlport-4.5.3/stlport/list:35,
> from libs/regex/build/../src/c_regex_traits.cpp:27:
> /core/elements/cots/stlport-4.5.3/stlport/stl/_pair.h:37: template with
> C linkage


It looks to me as though you've found an interaction between STLPort and the
solaris "C" headers. Perhaps somewhere there's an unterminated extern "C"
{... block?

If you look at the top of c_regex_traits.cpp, you'll see it begins:


    #include <clocale>
    #include <cstdio>
    #include <list>

And your problem has already happened by this point. So, I guess all I can
tell you is "it's not a Boost bug". You might try looking at the
preprocessed compiler output to see what's going on here.


Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at