Boost logo

Boost Users :

From: Jeff Flinn (TriumphSprint2000_at_[hidden])
Date: 2004-06-30 12:09:07

"Chris" <cpp_at_[hidden]> wrote in message news:cbuq4r$7h6$
> Hi Dave,
> this a sample of the example I tried to compile to see if the libs had
> #include "boost/filesystem/operations.hpp"
> #include "boost/filesystem/path.hpp"
> #include <iostream>
> The header file it could not find was the boost/filesystem/operations.hpp,
> even tried to use the angle brackets (just in case) but still no luck.

Which is the 1st include file seen, compilation stops here. So I'm guessing
that it's not finding any of the boost headers.

>From your original post:

> 1) I downloaded the latest version and decompressed it so that i have a
>"C:\boost_1_31_0 directory".

Is the directory really called: "C:\boost_1_31_0 directory"? If so you're
directory names are inconsistent. Also make sure you've got '0'(zero) and
not 'O'(capital oh).

> I have (with a bit of calm) tried to remove all the paths from VC++ and of
> course it tells me that it cannot find the header (which of course is
> normal) but when I add "C:\boost_1_31_0" to the list of INCLUDE
> in VC++ it keeps telling me: "fatal error LNK1104: cannot open file
> 'libboost_filesystem-vc71-sgd-1_31.lib' "

So are you now saying that you're compiling ok but not linking?

Does 'libboost_filesystem-vc71-sgd-1_31.lib' exist in the directory you've
specified in the LIBRARY entry?

Are you doing the compilation/link/build from the VC IDE? Did you create a
new console project?

Jeff Flinn

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at