Boost logo

Boost Users :

From: rflaperuta_at_[hidden]
Date: 2004-08-03 16:17:41


boost-users-bounces_at_[hidden] gravou em 03/08/2004 07:10:48:

> > this is one of the errors I got when compiling boost regex with vc7.1
+
>
> You get those errors if you build with STLPort *without* iostream
support.
>
> Unfortunately there are so many build variations possible (with or
without
> STLPort iostream, with or without /Zc:wchar_t, with or without
__STL_DEBUG)
> that it's almost impossible to diagnose errors via email (as a few
people on
> this list have already discovered - sorry about that).
Yeah Im one of those now ;-)

>
> Simplest option: add the source (in libs/regex/src) directly to your
> project, or else create a lib target in your IDE and build from there.

The stlport_test project you sent tweety some time ago, worked fine adding
the source to the project, but when I add the sources to my project it
gives an error about already defined symbols (STL symbols)

I know i'm pushing it on proposing this, but could you give some
step-by-step solution on building that lib target in vc71, this gave me
some errors also.....

The main goal is to use STLPORT + BOOST::REGEX + SPIRIT +
BOOST::SOMETHING_ELSE_I_DUNNO_YET in the project

>
> John.
>
> _______________________________________________
> Boost-users mailing list
> Boost-users_at_[hidden]
> http://lists.boost.org/mailman/listinfo.cgi/boost-users

Best Regards and thanks in advance for the Help....

RFL



Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net