Boost logo

Boost Users :

From: Douglas Gregor (doug.gregor_at_[hidden])
Date: 2005-02-19 18:45:39


On Thursday 10 February 2005 05:46 am, frantz.maerten_at_[hidden] wrote:
> I took a look at libsidc++ and found very interresting the way of
> blocking/unblocking connections.
>
> I added some small modifications in boost::signals lib in order to have
> this functionality (2 patches in attachment to apply at the parent of the
> boost_1_32_0 distrib). Only the interface of connection has changed (3 new
> methods), and I added a boolean flag in basic_connection struct.

I've checked in this code, modified slightly and with docs & tests. I made
three changes:
  - is_blocked() -> blocked(), to match the standard's naming conventions and
libsigc++
  - block() now takes a boolean parameter (again, matching libsigc++)
  - blocked() returns true when the slot is disconnected or blocked.

Thanks for the patch!

 Doug


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net