Boost logo

Boost Users :

From: Dave Snowdon (dave_at_[hidden])
Date: 2005-05-09 05:44:46


Has anyone successfully built boost on an Mac running MacOS 10.4? If so
I'd appreciate some pointers on what worked for you.

I've tried both boost 1.32 and a "fresh from CVS" copy with gcc 3.3 and
gcc 4.0 on a Powerbook G4 with 512Mb RAM with a fresh install of MacOS
10.4. The Mac has 1.15Gb free on the startup partition and 1.36Gb free
on the partition where I'm compiling boost. So far no attempt has met
with success. All builds were attempted from the Terminal app with no
other applications runnng.

Compiling boost 1.32 with gcc 4.0 (the default compiler on MacOS 10.4)
fails (unrecognised compiler version) because at the time 1.32 was
released gcc 4.0 was not available.

Compiling boost 1.32 with gcc 3.3 (bjam "-sTOOLS=darwin" "-sGCC=gcc-3.3"
"-sGXX=gcc-3.3" stage) gives some rather strange results. Link actions
seems to fail such as:

...failed darwin-Link-DyLib-action bin/boost/libs/date_time/build/libboost_date_time.dylib/darwin/debug/shared-linkable-true/libboost_date_time-d-1_32.dylib...

Almost all the calls to ld gives undefined symbol errors similar to (I'm
not sure if this is due to previously failed link actions):

darwin-Link-DyLib-action bin/boost/libs/date_time/build/libboost_date_time.dylib/darwin/debug/shared-linkable-true/libboost_date_time-d-1_32.dylib

ld: Undefined symbols:
















After about 15 minutes or so the Mac grinds to a halt and starts popping
up dialog boxes warning that the startup disk is full and then later
that "Your Mac OS X startup disk has no more space available for
application memory. To avoid problems with your computer quit any
applications you may not be using"

Using gcc 4.0 (bjam "-sTOOLS=darwin" stage) on the the CVS copy gives
many errors similar to this:

...failed darwin-C++-action bin/boost/libs/wave/build/libboost_wave.a/darwin/release/cpp_re.o...

...skipped <@boost!libs!wave!build/libboost_wave.a/darwin/release>libboost_wave-1_33.a for lack of <@boost!libs!wave!build/libboost_wave.a/darwin/release>instantiate_cpp_exprgrammar.o...

...skipped <@boost!lib>libboost_wave-1_33.a for lack of <@boost!libs!wave!build/libboost_wave.a/darwin/release>libboost_wave-1_33.a...

Previously I've been using boost 1.32 on a machine running Red Hat Linux
8 with gcc 3.2 and have not experienced any problems getting it to build.

Any advice appreciated....



Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at