Boost logo

Boost Users :

From: Jasper, Alexander (alexander.jasper_at_[hidden])
Date: 2005-08-15 10:59:17


If you are using VC7 rather VC 7.1 you of course use -sTOOLS=vc-7-stlport instead of -sTOOLS=vc-7_1-stlport.

But VC7 is crap. If it is possible I strongly recommend you to upgrade to 7.1 which really works a lot of better than any release before.

Also make sure you do a clean rebuild to prevent old compiler switches being stored in the precompiled header files.
Boost further requires you to enable the debug mode of stl-port, if I'm not mistakes. Adding the following to stl-user-config.h solved things for me.

#ifdef NDEBUG
#undef _STLP_DEBUG
#define _STLP_DEBUG 1

BTW. STLPort 4.6.2 does not work well in conjunction with boost.serialize. A bug in the ostream::write method prevents it from handling writing 0 bytes correctly. Unfortunately the serializer writes 0 bytes in case of empty strings for instance.

kind regards


> Thanks a lot for your reply! I tried your method and it
> works! All the compiler errors disappeared. I think the
> important thing is to turn the feature "stlport-iostreams" on.
> But the linker still asks me for something like
> "stlport_vc6.lib". I'm using vc7 now. And I built STLport
> 4.6.2 also with vc7. But the linker still asks me for
> something related to vc6. Does any one know the possible causes?
> _______________________________________________
> Boost-users mailing list
> Boost-users_at_[hidden]

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at