Boost logo

Boost Users :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2005-09-12 16:19:07


"Delfin Rojas" <drojas_at_[hidden]> wrote in message
news:200509121848.j8CImdkw014132_at_patti.moodlogic.com...
>> I'm planning to add a filesystem function to determine available disk
>> space.
>> Perhaps something like:
>>
>> struct space_status
>> {
>> boost::uintmax_t available; // free space available to user
>> boost::uintmax_t total; // total space on volume
>> };
>>
>> space_status filesystem_space( const path & p );
>>
>> Comments?
>>
>> Better suggestions for the names?
>>
>
> I think the word "status" in space_status is misleading since
> available/total space is not really a status. Maybe space_stats or simply
> space would be more appropriate?

I agree with you, but am worried that "space" is a very common name. OTOH,
the use is in a sub-namespace, so no harm done by using a common name.

Thanks,

--Beman


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net