Boost logo

Boost Users :

From: Jonathan Locke (jonathan_at_[hidden])
Date: 2008-06-18 08:12:52


I'm new to Boost and am trying to write a command line networking tool.
I am currently working in Windows XP SP2 using MS Visual Studio 2005. I
use the default compiler. I have read a few tutorials and examples on
using Asio, and thus wrote my app using that information, as well as
information from the reference library. Currently the problem that I
have is that I cannot set the port used by the endpoint to the value I
want - 10540 - it is always set to 11035. I'm not sure why this is, I
cant find the number 11035 anywhere in the code or documentation so I am
not sure where it comes from. I have tried to instantiate a new endpoint
using the IPv4 address as a string and the port number as a short, and
have also tried to construct a query that specifies the protocol, host
name, service name (port number in this case) and the numeric_service flag.

In either case, when I debug, the port of the endpoint is always 11035,
no matter what I set it to. I am able to connect to the endpoint, but
not able to write data to it. I get a "File handle supplied is not valid
error message". I presume the most likely reason for this is that the
port 11035 is not open.

The machine that I am trying to connect to is running Red Hat EL4 Update 4.

I would appreciate any help in this matter.

Thank you,

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at