Boost logo

Boost Users :

From: Andrea Denzler (andrea_at_[hidden])
Date: 2008-08-16 17:00:15


Isn't it easier to define those types?
        int16, int32, int64
        uint16, uint32, uint64

Of course the definition is determined by the platform using #ifdef code but
basically we have something like
        typedef unsigned short uint16;

It should be enough to handle most integer cases. Use always those types
when you need to know it's size and use explicit casting to other types when
needed to avoid the warning from bigger to smaller integer size or from
signed to unsigned. Try to reduce that situations in any case.

Andrea


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net