Boost logo

Boost Users :

Subject: Re: [Boost-users] boost::program_options
From: Eray Ozkural (examachine_at_[hidden])
Date: 2008-10-09 04:34:30

Duy Nguyen <dnguyen <at>> writes:

> When I try to use
> the boost::program_options library to read a property file,
> I got the error when
> I run "make" on Cygwin (I installed Cygwin on WIndows XP).
> >
> make
> g++.exe -I
> /cygdrive/c/MyTest/Test1/include/boost-1_34_1/
-c TestInit.cpp Test.cpp TestDriver.cppg++.exe -I
/cygdrive/c/MyTest/Test1/include/boost-1_34_1/ -c TestInit.cpp Test.cpp
TestDriver.cppg++.exe -I /cygdrive/c/MyTest/Test1/include/boost-1_34_1/ -c
TestInit.cpp Test.cpp TestDriver.cppg++.exe  TestInit.o Test.o TestDriver.o  -o
"TestDriver" -L/cygdrive/c/MyTest/Test1/lib
> -lboost_program_options-gcc34-mt-d-1_34_1 -lg2c
> Info: resolving vtable for
> boost::program_options::variables_mapby linking to
> __imp___ZTVN5boost15program_options13variables_mapE
> (auto-import)
> Then when I run my
> program, it does not work.
> If I comment out the
> "try ... catch" block which uses the boost::propram_options library then it
> compiles and works fine.
> Please show me how to fix it.
> Thank you.

I am getting exactly the same error with boost lib 1.34, 1.35, 1.36 and the gcc
4.3.0 that I built myself. On the latest and current cygwin. The program simply
doesn't work, silently exits, as if no arg processing is ever done.

Can you guys help me out? The same program builds and works fine on Mac OS and


Eray Ozkural

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at