Boost logo

Boost Users :

Subject: Re: [Boost-users] Building boost_1.34.1 on mac os X 10.5 64 bit.
From: Alain Leblanc (aalebl_at_[hidden])
Date: 2008-10-27 22:40:37

2008/10/27 Alexander Sack <pisymbol_at_[hidden]>:
> On Mon, Oct 27, 2008 at 9:26 PM, Alain Leblanc <aalebl_at_[hidden]> wrote:
>> 2008/10/27 Alexander Sack <pisymbol_at_[hidden]>:
>>>> Do you mean combined instead of x86? Using combined as a value for
>>>> either the address model or the architecture returns a message
>>>> indicating that it is not a valid value.
>>> Well I haven't done combined but what about 64 for address-model?
>>> -aps
>> Same result. With
>> ./tools/jam/src/bin.macosxx86/bjam architecture=x86
>> address-model=combined install
>> produces
>> ...
>> error: "combined" is not a known value of feature <address-model>
>> error: legal values: "16" "32" "64"
>> ...
>> and the same result with adding --toolset-darwin to the command line.
> Yes but if you do address-model=64, does that work? I would assume
> so. I don't think "combined" is going to work.
> -aps
> _______________________________________________
> Boost-users mailing list
> Boost-users_at_[hidden]

I tried all the combinations of

--toolset=darwin | <nothing>

Omitting --toolset=darwin gives me a warning that gcc is used but does
not change the result. Omitting the architecture parameter with
address-model=64 will compile but the resulting libraries are 32 bits.
With architecture=x86 and address-model=64 I get the message ' error:
CPU you selected does not support x86-64 instruction set.'

I'll download 1.36 and see if it willcompile. I think that all I need
to change to my code is a method that changed name in the filesystem
library. It may be faster than trying to compile 1.34.


Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at