Boost Users :
Subject: Re: [Boost-users] Formal Review: Boost.RangeEx
From: Alan M. Carroll (amc_at_[hidden])
Date: 2009-03-03 11:06:47
On Fri, Feb 20, 2009 at 12:28 PM, Thorsten Ottosen <firstname.lastname@example.org> wrote:
The 'ed naming is not good, and for consistency across Boost the _view
- - What is your evaluation of the design?
naming should be used.
However, in my mind map each of the adaptors is a verb rather than a noun, so
the expression should read as
rng | sort | unique
rng | sort_view | unique_view
Whereas when the function invocation syntax is used the _view naming seems to
express the intent more clearly. ie
unique_view( sort_view( rng ) )
Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net