Boost logo

Boost Users :

Subject: [Boost-users] [version 1.38.0] Problems with dynamic linking to boost libraries
From: Juan Antonio Farré Basurte (jafb_at_[hidden])
Date: 2009-03-10 13:55:08

I'm using boost libraries in my research work and I need to link to graph and program options libraries.
I've been working with
version 1.37.0 without any problem.
Now I updated to 1.38.0. I built the libraries in the same way and the same directories as 1.37.0 (on
The compilation and dynamic linkage phase work, but when I run the program it complains with "file not found" on the
shared library files.
I've tried it in my home Fedora 10 installation and the Debian installation at my workplace and I have the same
For the moment, the only workaround I've found is explicitly linking the static versions of both libraries, while still dynamically
linking to other libraries (like expat).
Is there any problem in the installation phase of "./configure ; make install"? What can I
Thanks in advance.

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at