Boost logo

Boost Users :

Subject: Re: [Boost-users] [version 1.38.0] Problems with dynamic linking to boost libraries
From: Juan Antonio Farré Basurte (jafb_at_[hidden])
Date: 2009-03-12 11:41:16

I've added /usr/local/lib to /etc/ and now it works.
What I don't understand is why the linker didn't complain (the problem was when
and why it worked before with 1.37.0.
Thanks a lot anyway,


> Juan Antonio Farré
Basurte wrote:
>> Hello,
>> I'm using boost libraries in my research work and I need to
link to graph and program options
>> libraries. I've been working with
>> version 1.37.0 without any problem.
Now I updated to 1.38.0. I built the libraries in the same way and the same directories as 1.37.0
>> (on /usr/local).
>> The
compilation and dynamic linkage phase work, but when I run the program it complains with "file
>> not found" on the shared
library files.
> You need to always provide the exact error message. Also, what does ldd say? Did you recompile your
> - Volodya
> _______________________________________________
> Boost-users
mailing list
> Boost-users_at_[hidden]

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at