Boost logo

Boost Users :

Subject: Re: [Boost-users] [phoenix] A simple lambda func as boost::function
From: Richard Vock (vock_at_[hidden])
Date: 2009-12-15 04:35:17

> I've now tried it with the following two combos:
> OS Compiler Boost Version Phoenix Version
> windows vc8 1_41_0 0x2000
> linux g++_4.3.2 1_39_0 0x2000
> Works fine for me. I only have gcc_4.3.2 on the virtual machine
> I was using. I'll reboot into linux later and check 4.4.2...
> but meanwhile, can you paste the error that you get with
> your setup and the source above?

Here's a paste of the lengthy error message:
Done with the setup from my previous post.

I tried upgrading to 1.41 (its now in the arch repos)
and *it does compile and work* without changing any
code. This looks as if the code from the previous
version has been corrupted but I never changed it myself,
so maybe I just stumbled upon a problem in the arch repos...

I myself am confident with a working 1.41, so as far as
my part in this ugly story goes: I'm fine and thank you
for your patience (I should have tried upgrading before
posting here but most of time *I* am the one who is wrong,
not the library source)!

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at