Boost logo

Boost Users :

Subject: Re: [Boost-users] [serialization] Can't build first example from docs.
From: Patrick Horgan (phorgan1_at_[hidden])
Date: 2009-12-29 18:49:59

Patrick Horgan wrote:
> Help! And thanks:) Same error as on our code. I thought I'd go through
> all the documentation (BTW do you want notes on typos?) and come up to
> speed so I could figure out why our code (that someone else wrote),
> had this error. To my surprise, the first example I tried had the same
> no get_debug_info member error. What am I doing wrong?
> Using trunk
> Using gcc 4.4.1 or 4.5
> Linux dell 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC
> 2009 i686 GNU/Linux
> make example1
> g++ -ggdb -ansi -pedantic -Wextra -Wwrite-strings -Wformat=2 -Wall
> -fstrict-aliasing -O3 -Wstrict-aliasing=3 -std=c++0x example1.cpp -o
> example1
> In file included from
> /usr/local/include/boost/archive/detail/abi_prefix.hpp:11,
> from /usr/local/include/boost/archive/shared_ptr_helper.hpp:35,
> from /usr/local/include/boost/archive/text_iarchive.hpp:100,
> from example1.cpp:5:
> /usr/local/include/boost/config/abi_prefix.hpp:12:3: error: #error
> double inclusion of header boost/config/abi_prefix.hpp is an error
> In file included from
> /usr/local/include/boost/archive/detail/abi_suffix.hpp:14,
> from /usr/local/include/boost/archive/text_iarchive.hpp:122,
> from example1.cpp:5:
> /usr/local/include/boost/config/abi_suffix.hpp:13:3: error: #error
> Header boost/config/abi_suffix.hpp must only be used after
> boost/config/abi_prefix.hpp
> In file included from
> /usr/local/include/boost/archive/detail/interface_oarchive.hpp:24,
> from /usr/local/include/boost/archive/detail/common_oarchive.hpp:20,
> from /usr/local/include/boost/archive/basic_text_oarchive.hpp:32,
> from /usr/local/include/boost/archive/text_oarchive.hpp:31,
> from example1.cpp:4:
> /usr/local/include/boost/archive/detail/oserializer.hpp: In static
> member function ‘static void
> boost::archive::detail::save_pointer_type<Archive>::polymorphic::save(Archive&,
> T&)’:
> /usr/local/include/boost/archive/detail/oserializer.hpp:441: error:
> ‘const class boost::archive::detail::basic_pointer_oserializer’ has no
> member named ‘get_debug_info’
I've solved this. For some reason ./bjam install, from boost-trunk,
didn't install the new boost/archive/detail/basic_serializer.hpp into
/usr/local/boost/archive/detail. When I deleted the old one that was
there it, and ran ./bjam install from boost_trunk again, it installed
fine and fixed this problem. Strange no? The ownership and permissions
of the old one were the same as everything else, but bjam wouldn't write
over it for some reason. There were no strange dates on it either.


Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at